Robert Haas <robertmh...@gmail.com> writes:
> On Sat, May 21, 2016 at 11:45 AM, Tom Lane <t...@sss.pgh.pa.us> wrote:
>> Yes, let's fix it.  This will also take care of the questions about
>> whether the GIN/GIST opclass tweaks I made a few months ago require
>> module version bumps.

> Tom, there's a patch for this at
> https://www.postgresql.org/message-id/574f091a.3050...@proxel.se which
> I think you should review, since you were the one who made the tweaks
> involved.  Any chance you can do that RSN?

I've pushed this with some revisions to make the queries more
search-path-safe.  I'm not too happy with the safety of the queries
I see already present from the previous patches.  I think stuff
like this:

UPDATE pg_proc SET proparallel = 's'
WHERE oid = 'min(citext)'::regprocedure;

needs to be more like

UPDATE pg_catalog.pg_proc SET proparallel = 's'
WHERE oid = 'min(citext)'::pg_catalog.regprocedure;

                        regards, tom lane


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to