David Rowley <david.row...@2ndquadrant.com> writes:
> The attached implements this, with the exception that I didn't really
> think AggPartialMode was the best name for the enum. I've named this
> AggregateMode instead, as the aggregate is only partial in some cases.
Hm. We already have an AggStrategy (for hashed vs. grouped aggregation)
so adding AggregateMode beside it seems somewhere between confusing and
content-free. And it's needlessly inconsistent with the spelling of the
existing enum name. I'm not wedded to "AggPartialMode" but I think
we need some name that's a bit more specific than "AggregateMode".
regards, tom lane
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: