On 26 June 2016 at 04:07, Tom Lane <t...@sss.pgh.pa.us> wrote:
> I wrote:
>> David Rowley <david.row...@2ndquadrant.com> writes:
>>> The attached implements this, with the exception that I didn't really
>>> think AggPartialMode was the best name for the enum. I've named this
>>> AggregateMode instead, as the aggregate is only partial in some cases.
>> Hm.  We already have an AggStrategy (for hashed vs. grouped aggregation)
>> so adding AggregateMode beside it seems somewhere between confusing and
>> content-free.  And it's needlessly inconsistent with the spelling of the
>> existing enum name.  I'm not wedded to "AggPartialMode" but I think
>> we need some name that's a bit more specific than "AggregateMode".
>> Suggestions anyone?
> After a bit of thought, maybe AggDivision or AggSplit or something
> along those lines?

How about AggCompletion? It's seems to fit well in the sense of the
aggregation being partial or not, but less well when you consider
serialisation and combining states.

 David Rowley                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to