Tom Lane wrote:

> So far as I can find, the attached is all we need to do to introduce a
> new message field.  (This patch doesn't address the memory-context
> questions, but it does fix the localization-driven failure demonstrated
> upthread.)
> Any objections?  Anyone want to bikeshed the field name?  I considered
> on PG_DIAG_SEVERITY_ASCII, but I can't say I'm in love with that.

I didn't review the patch, but +1 on the idea.  As for the name, I think
ASCII is the wrong thing (as many labels in other languages can be in
ascii too).  I vote for NONLOCALIZED.

I see character "s" is already taken in the protocol; that would be my
first preference rather than A.  How about Z?

Álvaro Herrera      
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to