On Tue, Sep 27, 2016 at 8:39 PM, Thomas Munro <thomas.mu...@enterprisedb.com> wrote: > Ok, if they really are independent then shouldn't we take advantage of > that at call sites where we might be idle but we might also be waiting > for the network?
I certainly didn't intend for them to be independent, and I don't think they should be. I think it should be a hierarchy - as it is currently. I think it's a bad idea to introduce the notational overhead of having to pass through two integers rather than one everywhere, and a worse idea to encourage people to think of the wait_event_type and wait_event are related any way other than hierarchically. > Actually, I'm still not sold on "Activity" and "Client". I think > "Idle" and "Network" would be better. Everybody knows intuitively > what "Idle" means. "Network" is better than "Client" because it > avoids confusion about user applications vs replication connections or > clients vs servers. Hmm, I could live with that, if other people like it. > s/auxilliary/auxiliary/, but I wouldn't it be better to say something > more general like "from another process in the cluster"? Background > workers are not generally called auxiliary processes, and some of > these wait points are waiting for those. Agreed; or perhaps it could even be waiting for another regular backend. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers