Stephen Frost <sfr...@snowman.net> writes:
> * Peter Eisentraut (peter.eisentr...@2ndquadrant.com) wrote:
>> I'm OK with just removing all the source codes from the \d family and
>> using the \s family instead.
> Ok, great, thanks for clarifying that. Since we only have '\sf' today,
> I think the prevailing option here is then to make the change to
> removing 'prosrc' from \df+, have an 'internal name' column, and have
> users use \sf for functions.
I'm not sure that Peter was voting for retaining "internal name", but
personally I prefer that to deleting prosrc entirely, so +1.
> Personally, I like the idea of a '\sv' for views, though we should
> discuss that on a new thread.
We have \sv already no?
I'm kind of -1 on removing view definitions from \d+. It's worked like
that for a very long time and Peter's is the first complaint I've heard.
I think changing it is likely to annoy more people than will think it's
regards, tom lane
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: