On Thu, Oct 20, 2016 at 12:29:47PM -0400, Robert Haas wrote: > > When it comes to the name, I tend to think of 'pg_xact' as saying "this > > is where we persist info we need to keep about transactions." Today > > that's just the commit status info, but I could imagine that there > > might, someday, be other things that go in there. "pg_multixact" is > > an example of something quite similar but does have more than just one > > "thing." Also, using "pg_xact" and then "pg_subxact" and "pg_multixact" > > bring them all under one consistent naming scheme. > > I don't dispute the fact that you tend to think of it that way, but I > think it's a real stretch to say that "pg_xact" is a clear name from > the point of view of the uninitiated. Now, maybe the point is to be a > little bit deliberately unclear, but "xact" for "transaction" is not a > lot better than "xlog" for "write-ahead log". It's just arbitrary > abbreviations we made up and you either know what they mean or you > don't. We could call it "pg_xkcd" and we wouldn't be removing much in > the way of clarity.
What is your suggestion for a name? If you have none, I suggest we use "pg_xact". -- Bruce Momjian <br...@momjian.us> http://momjian.us EnterpriseDB http://enterprisedb.com + As you are, so once was I. As I am, so you will be. + + Ancient Roman grave inscription + -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers