On Thu, Oct 20, 2016 at 12:05 PM, Stephen Frost <sfr...@snowman.net> wrote:
>> To be honest, I don't really like either pg_transaction or pg_xact.
>> Neither name captures the fact that what we're really tracking here is
>> the transaction *status*. pg_xact is slightly worse because it's a
>> poor abbreviation for transaction, but I think the argument against
>> even pg_transaction is similar to the one Tom previously levied
>> against pg_logical - viz. "logical what?". The transaction themselves
>> are not stored in the directory, just the commit status. The fact
>> that commit status is saved is the source of the "c" in "clog".
> This really needs to move forward also.
> When it comes to the name, I tend to think of 'pg_xact' as saying "this
> is where we persist info we need to keep about transactions." Today
> that's just the commit status info, but I could imagine that there
> might, someday, be other things that go in there. "pg_multixact" is
> an example of something quite similar but does have more than just one
> "thing." Also, using "pg_xact" and then "pg_subxact" and "pg_multixact"
> bring them all under one consistent naming scheme.
I don't dispute the fact that you tend to think of it that way, but I
think it's a real stretch to say that "pg_xact" is a clear name from
the point of view of the uninitiated. Now, maybe the point is to be a
little bit deliberately unclear, but "xact" for "transaction" is not a
lot better than "xlog" for "write-ahead log". It's just arbitrary
abbreviations we made up and you either know what they mean or you
don't. We could call it "pg_xkcd" and we wouldn't be removing much in
the way of clarity.
The Enterprise PostgreSQL Company
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: