Hello, At Thu, 17 Nov 2016 10:00:53 +0800, Craig Ringer <cr...@2ndquadrant.com> wrote in <camsr+yemms8xp8oj6vu2j+tm3sp_anjcl3k6tsofk2fxaux...@mail.gmail.com> > On 17 November 2016 at 00:01, Michael Paquier <michael.paqu...@gmail.com> > wrote: > > On Tue, Nov 15, 2016 at 11:32 PM, Noah Misch <n...@leadboat.com> wrote: > >> On Wed, Nov 16, 2016 at 12:48:03PM +0800, Craig Ringer wrote: > >>> --- a/src/test/perl/README > >>> +++ b/src/test/perl/README > >>> @@ -64,3 +64,20 @@ For available PostgreSQL-specific test methods and > >>> some example tests read the > >>> perldoc for the test modules, e.g.: > >>> > >>> perldoc src/test/perl/PostgresNode.pm > >>> + > >>> +Required Perl > >>> +------------- > >>> + > >>> +Tests must run on perl 5.8.8 and newer. perlbrew is a good way to obtain > >> > >> Tests must run on Perl 5.8.0 and newer. > > Why? We've always discussed 5.8.8 before. That's already a full 10 years old. > > 5.8.0 is from *2002*. Are you running any 15-year-old systems you > can't update to a *patch release* of the same perl major? > > > gendef.pl says it needs 5.8.0 or newer with "use 5.8.0" but that's the > only relevant thing I can find, and it's not relevant to the TAP tests > anyway. > > BTW, here's my older approach, with a dockerfile, before I became > aware of perlbrew: > > https://www.postgresql.org/message-id/camsr+ygr6pu-guyp-ft98xwxasc9n6j-awzaqxvw_+p3rtc...@mail.gmail.com > > > 5.8.8 is in CentOS 5. > > Debian Lenny (6) has 5.14.2 Wheezy (5) has 5.10. Etch (4) has 5.8.8. > Etch came out in early 2007. Even Sarge had 5.8.4. > > Ubuntu 10.04 Lucid (old-lts) had 5.10.1-8ubuntu2 . > > So unless we care about Debian 3 Sarge or source builds done more than > 10 years ago, 5.8.8 is more than good enough.
I vote +1 to upgrading perl, but I'm not sure if all supporting platforms other than linux support the version of perl. Anyway ./configure is saying as the following. | *** The installed version of Perl, $PERL, is too old to use with PostgreSQL. | *** Perl version 5.8 or later is required, but this is $pgac_perl_version." >&5 If TAP test requires 5.8.8, the whole build sequence should follow that. Or at least ./configure --enable-tap-tests should check that. regards, -- Kyotaro Horiguchi NTT Open Source Software Center -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers