On 17 November 2016 at 10:31, Kyotaro HORIGUCHI
<horiguchi.kyot...@lab.ntt.co.jp> wrote:

> I vote +1 to upgrading perl, but I'm not sure if all supporting
> platforms other than linux support the version of perl.
> Anyway ./configure is saying as the following.
> | *** The installed version of Perl, $PERL, is too old to use with PostgreSQL.
> | *** Perl version 5.8 or later is required, but this is $pgac_perl_version." 
> >&5
> If TAP test requires 5.8.8, the whole build sequence should
> follow that. Or at least ./configure --enable-tap-tests should
> check that.

I wrote 5.8.8 because that's what we've always discussed before and I
could honestly not imagine it mattering whether we require 10-year or
15-year old Perl. Especially for the TAP tests, which are new, and

I really don't think it matters if the TAP tests use a slightly newer
Perl. They're optional and not enabled by default. Can we just
document this please? I didn't think a four-line docs patch to an
optional, non-default, new test suite would require this kind of

But sure, if it's easier, we can have 5.8.0 in the README. What's five
extra years matter anyway? Hey, while we're at it, lets change Pg to
build on Borland C and require K&R style!

 Craig Ringer                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to