Maybe something like the following, or maybe it should include "bufmgr.h",
As-is this patch seems like a maintenance time bomb; it really needs to
use the #defines rather than have the values hard-wired in. However, just
including bufmgr.h in frontend code doesn't work, so I moved the #defines
to pg_config_manual.h, which seems like a more reasonable place for them
anyway. Pushed with that and some other polishing.
Indeed, that's much cleaner and easier to maintain. Thanks.
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: