Here's backtrace and some debugging information
Program terminated with signal 11, Segmentation fault.
#0  0x00000000007f96cd in shm_mq_sendv (mqh=0x121e998,
iov=0x7ffc9b7b79f0, iovcnt=2, nowait=1 '\001') at shm_mq.c:357
357        Assert(mq->mq_sender == MyProc);
(gdb) where
#0  0x00000000007f96cd in shm_mq_sendv (mqh=0x121e998,
iov=0x7ffc9b7b79f0, iovcnt=2, nowait=1 '\001') at shm_mq.c:357
#1  0x00000000006d8387 in mq_putmessage (msgtype=88 'X', s=0x0, len=0)
at pqmq.c:165
#2  0x0000000000515147 in ParallelWorkerMain (main_arg=141900502) at
#3  0x0000000000783063 in StartBackgroundWorker () at bgworker.c:726
#4  0x0000000000795b77 in do_start_bgworker (rw=0x1216f00) at postmaster.c:5535
#5  0x0000000000795e4f in maybe_start_bgworker () at postmaster.c:5710
#6  0x0000000000794eb3 in sigusr1_handler (postgres_signal_arg=10) at
#7  <signal handler called>
#8  0x00002b005933a693 in select () from /lib/x86_64-linux-gnu/
#9  0x0000000000790720 in ServerLoop () at postmaster.c:1665
#10 0x000000000078fe76 in PostmasterMain (argc=8, argv=0x11eef40) at
#11 0x00000000006d8f1d in main (argc=8, argv=0x11eef40) at main.c:228
(gdb) p mq->mq_sender
Cannot access memory at address 0x6b636568635f707d
(gdb) p mq
$1 = (shm_mq *) 0x6b636568635f706d

Looking at this, I am wondering, how could that happen with your
patches. But every time I have tried to apply your patches and run
regression, I get this crash. Just now I tried the patches on a all
new repository and reproduced the crash.

On Tue, Nov 29, 2016 at 3:10 PM, Haribabu Kommi
<> wrote:
> On Tue, Nov 22, 2016 at 9:46 PM, Ashutosh Bapat
> <> wrote:
>> It could be because of some un-initialised variable, which is
>> initialized appropriately by default on your machine but not on my
>> machine. I first applied your pg_hba_rules... patch, ran regression.
>> It didn't crash. then I applied patch for discard_hba... and it
>> started crashing. Does that give you any clue? Here's regression.out
>> file for make installcheck. Here is error log snippet that shows a
>> SIGSEGV there.
>> 2016-11-22 15:47:11.939 IST [86206] LOG:  worker process: parallel
>> worker for PID 86779 (PID 86780) was terminated by signal 11:
>> Segmentation fault
>> 2016-11-22 15:47:11.939 IST [86206] LOG:  terminating any other active
>> server processes
>> 2016-11-22 15:47:11.939 IST [86779] WARNING:  terminating connection
>> because of crash of another server process
>> 2016-11-22 15:47:11.939 IST [86779] DETAIL:  The postmaster has
>> commanded this server process to roll back the current transaction and
>> exit, because another server process exited abnormally and possibly
>> corrupted shared memory.
>> Applying those patches in any order doesn't matter.
> I am not able to reproduce the crash both in debug and release mode
> builds with both check and installcheck options.
> Can you please share the back trace of the crash, so that it will be helpful
> for me to locate the problem.
> Regards,
> Hari Babu
> Fujitsu Australia

Best Wishes,
Ashutosh Bapat
EnterpriseDB Corporation
The Postgres Database Company

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to