On Thu, Jan 5, 2017 at 5:10 AM, Simon Riggs <si...@2ndquadrant.com> wrote:
> On 4 January 2017 at 03:54, Haribabu Kommi <kommi.harib...@gmail.com> wrote:
>> Latest patch is attached.
> The "method" column should be called "auth" or "auth_method" or 
> "authentication"
> I think we should have some tests, but I'll hear your views on that.
> Perhaps we can include a test/sample pg_hba.conf for use in tests.
> Since we've had crashes, I suggest running the test 10000 times and
> checks for leaks and crashes.
> If its safe we can move towards commit. Thanks

Could you hold on a bit to commit that? I'd like to look at it in more
details. At quick glance, there is for example no need to use
CreateTemplateTupleDesc and list the columns both in pg_proc.h and the
C routine itself. And memset() can be used in fill_hba_line for the
error code path.

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to