Robert Haas <robertmh...@gmail.com> writes: > I guess it does seem likely that most users of the hook would need to > do the same, but it seems confusing to pass the same function both x > and f(x), so my vote is to not do that.
I guess what's in the back of my mind is that the password type might someday not be just a function of the password, but require other inputs. That is, if we change the hook signature as proposed, then the signature of get_password_type() also becomes part of that API. If someday f(x) needs to become f(x,y), that becomes either more API breakage for users of the hook, or no change at all because it's the callers' problem. Maybe there's no reason to believe that that will ever happen. > But I'm not disposed to spend > a lot of energy arguing about it, so if other people feel differently, > that's cool. TBH, I'm not that hot about it either. But I'm thinking this is an API break we don't need. regards, tom lane -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers