On Aug 14, 2007, at 12:40 , Tom Lane wrote:

Josh Berkus <[EMAIL PROTECTED]> writes:
The problem here is that "log" seems to be a verb in "log_collector"
which is what makes it confusing. So we need another verb to make it clear that "log" is not one. This is not a problem with "autovacuum"
because that one cannot be confused with a verb.

start_log_collector still gets my vote.

log_collector_enable or log_collector_start or even log_redirect. But
something with log_*

I'm voting with Alvaro on this.  All of your suggestions are confusing
because "log" looks like the verb, which it is not. Specifically, they sound like what the switch does is to cause a log message to be emitted
about some action that would occur anyway.

AIUI, if the-GUC-yet-to-be-named is not enabled, no logging is done at all: messages are just sent to stderr. Why something simple like enable_logging or start_logger?

Michael Glaesemann
grzm seespotcode net

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to