On Thursday 16 August 2007 04:29:41 Andrew Dunstan wrote:
> Michael Meskes wrote:
> > Hi,
> >
> > we have two build farm members failing to make since I committed teh
> > ecpg changes: echidna and herring.
> >
> > It looks like they are still using an old preproc.c although they
> > checked out the new preproc.y. I have no idea how this is supposed to
> > work so could someone please enlighten me?
> Yes it looks like that. But the buildfarm client doesn't actually build
> in the repo normally - it builds in a temp copy which is removed at the
> end of the run, precisely to avoid this kind of problem, so I'm a bit
> mystified how it can happen. In fact we go to some lengths to ensure
> that there are no extraneous files, but this one might not get caught by
> that because it is is in .cvsignore. This sort of thing is usually a
> symptom of somebody having run a build in the repo directly, a thing
> that buildfarm owners have been repeatedly advised not to do.

This is something I do not recall doing, however it's possible.  though this 
does make me ask why are the build dependencies in the Makefile are not 
properly setup to tell that the .y needs to be rebuilt (which I would assume 
would make this problem also go away)

> Anyway, the simple solution is to ask Darcy to blow away the repo (these
> buildfarm clients share a single cvs checkout) so that the buildfarm
> client will get a fresh checkout next time it's run.

Let me go nuke the tree, and we'll try again....

> cheers
> andrew
> ---------------------------(end of broadcast)---------------------------
> TIP 5: don't forget to increase your free space map settings

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to