On 9/26/07, Zdenek Kotala <[EMAIL PROTECTED]> wrote:
> Mark Wong wrote:
> > On 9/25/07, Satoshi Nagayasu <[EMAIL PROTECTED]> wrote:
> >> Mark,
> >>
> >> Very interesting. I'm looking for such tool.
> >>
> >> Unfortunately, I can't compile it on my Solaris right now,
> >> but I hope it will be shipped with PostgreSQL distribution.
> >
> > I haven't tried it on Solaris but I'm not surprised.  If I can get my
> > hands on a Solaris system I can probably get it to work. :)  The code
> > for getting the process information is platform specific and I know
> > I've broken it for all the platforms I haven't tried it on...
> Mark,
> I tested it on Solaris and I found two problems there. One is with
> configure. It does not correctly handled CPPFLAGS. Generated makefile
> ignore path to the include files. This line is wrong:
> # explicit dependency for the module appropriate to this machine
> m_sunos5.o: $(srcdir)/machine/m_sunos5.c
>         $(COMPILE) -o $@ -c $(srcdir)/machine/m_sunos5.c
> Second issue is with new interface of get_process_info function.
> Currently it has 4 arguments but in m_sunos5.c is defined only with 3
> arguments.
> Last issue is with -m64 switch. Solaris pg installation does not have
> 64bit libpg (will be soon) and linker is not able put everything together.

Hi Zdenek,

I don't have a Solaris system to work on.  Would you be able to send a
patch?  I have a mercurial repository, info here:

I think I've already caught the CPPFLAGS problem too.


---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to