On 10/18/07, Tom Lane <[EMAIL PROTECTED]> wrote:
> "Merlin Moncure" <[EMAIL PROTECTED]> writes:
> > There was a very similar proposal a little while back (google:
> > array_to_set).  I think I like those names better since you are
> > returning a set, not an iterator :-).
> I agree, this is a very poor choice of name.  There should be some
> reference to arrays in it, for one thing.
> generate_array_subscripts() maybe?

array_to_set or array_expand seem a little better imo (shorter, and
symmetry with array_accum()), unless you want to differentiate between
internal funcs (array_cat and the like) vs. user funcs.

I would prefer a proper C implementation to a solution based around
generate_series().  I'm doing a lot of C funcs lately and would be
happy taking a stab at this...


---------------------------(end of broadcast)---------------------------
TIP 5: don't forget to increase your free space map settings

Reply via email to