Neil Conway wrote:
> On Sat, 2007-01-20 at 00:21 +0100, Gevik Babakhani wrote:
> > AFAIK, It is/was part of the TODO for the core.
> Well, I don't have a strong opinion either way, but I think it should be
> given some thought.
> As far as the code, looks pretty good. A few minor comments:
> * varchar_uuid() should be named uuid_varchar(), for consistency with
> the other function names. In fact, uuid_text() and varchar_uuid() are
> essentially identical, so they should be refactored. The fmgr interface
> macros can stay, I guess.
> * most of uuid.h can be gotten rid of: the SQL-callable functions are
> already declared in builtins.h, and most of the other declarations
> should be moved to uuid.c and made local to that file.
> * needs documentation

I think having it in core makes the most sense.

  Bruce Momjian   [EMAIL PROTECTED]

  + If your life is a hard drive, Christ can be your backup. +

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to