Heikki Linnakangas <[EMAIL PROTECTED]> writes:
>> I'll post a patch along those lines.

> Here it is.

> I'm not fond of the macro names for the flag, but couldn't think of 
> anything shorter yet descriptive.

Let's reverse the sense of the flag bit; this seems a good idea since
the initial state should be 0 = there are no free pointers.  Also I'd
go with PD_ as the prefix, for consistency with the field names.
This brings us to PD_HAS_FREE_LINE_POINTERS or some abbreviation thereof
(maybe PD_HAS_FREE_LINES is sufficient).

I'd also go with "pd_flags" as the field name; "amprivate" seems to
imply way too much about what we might later use the flags for.

Barring objections, I'll tweak this as above and apply.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to