Hash: RIPEMD160

Tom Lane reports:

>> The version I tested against is 5.8.8 -  the latest stable release. The 
>> 5.8 series started in 2003 from what I can see - if anyone has a 
>> sufficiently old system that they can test on 5.6.2 that will be useful. 

> I got around to trying it with a dusty 5.6.1 I have laying about on my
> HPPA machine, and the news is not good: CREATE LANGUAGE plperl dumps
> core deep inside libperl.  With or without this patch.

Sounds like another good reason to start enforcing a minimum modern Perl 
version. In the past, I advocated making it a minimum of 5.6, but now I 
think a minimum of 5.8 is in order. The first version of 5.8 was released 
in July of 2002, so I don't think we'd be upsetting very many people if 
we did so. Plus, they'd be potentially dumping core anyway, and our energy 
is better spent improving Pl/Perl itself at this point rather than tweaking 
things for old versions of Perl. I don't even think I have a pre 5.8 
version around anymore. Would such a requirement cause any problems with 
packagers? I imagine a perl 5.8 prereq is a common thing these days...

- --
Greg Sabino Mullane [EMAIL PROTECTED]
PGP Key: 0x14964AC8 200712011322


---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?


Reply via email to