> On 4 Apr 2018, at 09:58, Peter Uhnák <i.uh...@gmail.com> wrote:
> 
> Would it be possible to instead have a #haltIf object to which you can send 
> additional conditions?
> 
> E.g.
> 
> self haltIf insideTest
> self haltIf outsideTest
> 
> Makes it (imho) a bit more readable, adds just a single method to Object, and 
> allows for more potential extensions...
> 
> self haltIf nil.
> self haltIf count: 3.
> 

Interesting. I will make a not.

Another thing to think about is that all this “combination” stuff might be 
where a BreakPoint system with a good UI actually starts to be
better than a textual halt.

The power of the Smalltalk #halt lies to some extend it its radical simplicity.

        Marcus


Reply via email to