Hi,

I'm working on a class and when a user submits a form to add a new product, I'm calling the addProduct method and within that method I call another method of the class 3 times. Once for a thumbnail image, once for a preview image and once for the full image, is this considered the correct approach ???

function myMethod (){

        myOtherFunc("full");
        myOtherFunc("preview");
        myOtherFunc("thumb);

}

Id that the best way to write it ?? It would appear to only have 1 method running at any one time, so making them work in succession would be the obvious answer:

function myMethod (){

        if(myOtherFunc("full")){
                if(myOtherFunc("preview")){
                        if(myOtherFunc("thumb)){
                                echo "all methods returned true!";
                        } else {
                                echo "last method returned false!";
                        }
                } else {
                        echo "2nd method returned false!";
                }
        } else {
                echo "1st method returned false!";
        }
}

Is there not a better way of handling this function chain (for want of a better word) ???

Thanks,

Jon


jon bennett | [EMAIL PROTECTED] new media designer / developer _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

J b e n . n e t

91 Gloucester Rd,  Trowbridge,  Wilts,  BA14 0AD
t: +44 (0) 1225 341039 w: http://www.jben.net/


On 1 Dec 2003, at 16:05, Jon Bennett wrote:


Down't worry, it's sorted!

Cheers,

Jon


jon bennett | [EMAIL PROTECTED] new media designer / developer _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

J b e n . n e t

91 Gloucester Rd,  Trowbridge,  Wilts,  BA14 0AD
t: +44 (0) 1225 341039 w: http://www.jben.net/


On 1 Dec 2003, at 15:57, Jon Bennett wrote:


I'm trying to return a value if the file uploads correctly, using return, but I don't seem to be getting anything back.

I've added this to my storeImages method

return = $aNewImage['new_name'];

and when I call the method from my addProduct() method I use this:

$sThumbnailFileName = $this->_storeImages($iProductId, $aArgs["Image"], 'thumb');

I then assumed I'd be able to just reference the $sThumbnailFileName var so I can insert the filename into the db, but it always goes in blank, does $sThumbnailFileName not get returned $aNewImage['new_name'], or is it stuck in an array or something ??

Thanks,

Jon


jon bennett | [EMAIL PROTECTED] new media designer / developer _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

J b e n . n e t

91 Gloucester Rd,  Trowbridge,  Wilts,  BA14 0AD
t: +44 (0) 1225 341039 w: http://www.jben.net/


On 1 Dec 2003, at 15:26, Jon Bennett wrote:


well I'll be dammed, that was it! Geeze, you look at something for so long sometimes you can't see the wood for the trees!!!!

I feel sooooo stoopid now!

Thanks,

Jon


jon bennett | [EMAIL PROTECTED] new media designer / developer _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

J b e n . n e t

91 Gloucester Rd,  Trowbridge,  Wilts,  BA14 0AD
t: +44 (0) 1225 341039 w: http://www.jben.net/


On 1 Dec 2003, at 15:10, Pavel Jartsev wrote:


Jon Bennett wrote:
Just to clarify about using move_uploaded_file()
...
function addProduct(){
// Move the uploaded file to the correct location
move_uploaded_file($$_FILES["image"]["tmp_name"], BASE_DIR."/_img/_products/".$iProductId."_".$fileName);
}
...


function storeBigImage($ID, $aImage){

// create filenames
fopen($aImage['name'], 'r');
$aNewImage['real_name'] = $aImage['name'];
$aNewImage['new_name'] = $ID . '_' . 'big' . '_' . $aNewImage['real_name'];
$aNewImage['image_loc'] = BASE_DIR . '_lib/_products/' . $aNewImage['new_name'];
...


Just noticed one thing... maybe it's just a typo, but directory, where You save uploaded image isn't the same in those examples.

In "move_uploaded_file()" it contains "_img/...", but in "storeBigImage()" there is "_lib/...". And therefore first case is working and second isn't.


-- Pavel a.k.a. Papi

--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php


-- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php


-- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php


-- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php


-- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php



Reply via email to