You got to be kidding me!!!!  I use similar code and a sample of yours and I
got just about the same error message as what Jeff Bluemel got.  I checked
the PHP Info and it showed that I had the libmcrypt accepted but no
supported ciphers.  Then I posted two seperate unanswered posting until I
stumpled onto this.

I did not understand why mcrypt is required along with the libmcrypt.
Libmcrypt is just an combination of mcrypt and extra stuffs.  The url, said to use libmcrypt and it mentioned of no mcrypt.  So, it
was no wonder I had problem.  Now I know I did not ask the right question in
the PHP newsgroup.  I am glad to see a solution to this problem.  Thank you
for the responses and your solution to the problem as it help with Jeff
Bluemel, it now helped me too.  Thank you!


P.S. Do I compile mcrypt before libmcrypt or is it the other way around?

"Tom Rogers" <[EMAIL PROTECTED]> wrote in message
> Hi,
> Friday, October 4, 2002, 3:01:53 PM, you wrote:
> JB> I've seen a few other post on this, and it sounds like there is more
> JB> one of use that is trying this script.  I've got it so that I can use
> JB> commands, but I still get errors on the page...
> JB> here is what I have done.
> JB> I downloaded libmycrpt from
> JB> and configured it
> JB> the following options;
> JB> ./configure \
> JB>  --with-included-algos="rijndael-128 arcfour stream cbc cfb"\
> JB>  --disable-posix-threads
> That is a class I put together. I use libmcrypt-2.5.2 configured with:
> configure --prefix=/usr --enable-ltdl-install=no
> and mcrypt-2.6.2 configured with:
> configure --prefix=/usr
> and in php configure:
> --with-mcrypt=/usr/src/mcrypt-2.6.2 (thats where it was untarred)
> and it works like a dream :)
> --
> regards,
> Tom

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to