Edit report at https://bugs.php.net/bug.php?id=75042&edit=1

 ID:                 75042
 Comment by:         jbbo...@php.net
 Reported by:        jbbo...@php.net
 Summary:            run-tests.php issues with EXTENSION block on windows
 Status:             Open
 Type:               Bug
 Package:            Testing related
 Operating System:   Windows 10
 PHP Version:        7.2.0beta2
 Block user comment: N
 Private report:     N

 New Comment:

Sorry, after reviewing, I believe that one may be an issue with my setup. I 
will revert that and update the PR.

The only thing I don't understand is why that is run with -n but the tests 
aren't also invoked with it.


Previous Comments:
------------------------------------------------------------------------
[2017-08-06 22:58:16] der...@php.net

I'm relatively certain that I added that "-n" for a good reason.

------------------------------------------------------------------------
[2017-08-06 21:50:17] jbbo...@php.net

The following patch has been added/updated:

Patch Name: run-tests-windows-extension.patch
Revision:   1502056217
URL:        
https://bugs.php.net/patch-display.php?bug=75042&patch=run-tests-windows-extension.patch&revision=1502056217

------------------------------------------------------------------------
[2017-08-06 21:50:02] jbbo...@php.net

Description:
------------
There are a few issues with using the EXTENSION block in phpt on windows.

1) Commands are not properly escaped for windows. This causes a parse error and 
the error output to be attempted to be included in following commands as an 
argument.
2) Extensions to be loaded need the "php_" prefix on Windows.
3) Specifying "-n" to check loaded modules causes "Module already loaded"
warning. This causes the tests to fail (at least on windows) due to the extra 
output.

Please see my attached patch.

Test script:
---------------
Reproduction is a bit tricky. The latest commit as of now (046ab3a) in this 
branch can reproduce the issue:
https://github.com/jbboehr/php-handlebars/tree/windows
https://ci.appveyor.com/project/jbboehr/php-handlebars/build/windows.7/job/35ge6iux3k0xa8kb#L2468

But I believe the issue can be reproduced by simply using EXTENSION in a phpt 
on windows.



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=75042&edit=1

-- 
PHP Quality Assurance Mailing List <http://www.php.net/>
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to