Hi All,

During the creating of some samples for PHP Quebec, I noticed a few
minor niggles I think we could improve.:

1.  @binding.ws - 'ws' is not particularly meaningful.  I think we're
unlikely to support anything other than soap with this binding, so
think @binding.soap would be much better.
2.  @binding.rest.rpc - we have @binding.jsonrpc and @binding.xmlrpc.
I think we should change this one to @binding.restrpc for consistency.
3.  Complex types declarations - we currently require developers to
specify @param <type_name> <namespaceURI> <Description> .  This is a
bit of an abuse of phpDocumentor and slighly breaks the documentation
generation.  It is also a little difficult to read (I always expect
them to be the other way round, but the type name is first for
phpDocumentor.).  I would like to propose we change this to @param
<namespaceURI>#<type_name> <Description>.

I wanted to discuss these here because if we make the changes, then
people's code will break.  Thoughts?

Regards, Graham.

You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to