I already replied to this last week, but as some others have reported, 
and not for the first time, my post (which I composed within Google 
Groups in the browser) never showed up. In future I'm going to try to 
make a habit of posting via email. This may eliminate missing posts, and 
even if it doesn't I get to keep a copy so I can resend if necessary.

Anyway, here's a rehash of my reply:


> 1.  @binding.ws - 'ws' is not particularly meaningful.  I think we're
> unlikely to support anything other than soap with this binding, so
> think @binding.soap would be much better.

Agreed, binding.ws is pointlessly general.

> 2.  @binding.rest.rpc - we have @binding.jsonrpc and @binding.xmlrpc.
> I think we should change this one to @binding.restrpc for consistency.

The specifications being implemented are actually JSON-RPC and XML-RPC, 
right? But there is a lot of precedent for using the names jsonrpc and 
xmlrpc in existing code, including the corresponding PHP extensions, so 
I suppose we should go the same way. I think the idea with rest.rpc was 
to allow some sort of inheritance between different flavours of REST, 
but there's more than one way to achieve that. So yes, go for consistency.

> 3.  Complex types declarations - we currently require developers to
> specify @param <type_name> <namespaceURI> <Description> .  This is a
> bit of an abuse of phpDocumentor and slighly breaks the documentation
> generation.  It is also a little difficult to read (I always expect
> them to be the other way round, but the type name is first for
> phpDocumentor.).  I would like to propose we change this to @param
> <namespaceURI>#<type_name> <Description>.

I was responsible for changing the separator in the pretty-print output 
from namespaceURI:type_name to namespaceURI#type_name a while back, so I 
should explain why - it was because the SDO extension sometimes creates 
formatted output directly itself and sometimes just passes through 
formatted output created within the Tuscany SDO library, and I wanted 
them to be consistent, so I chose to go with the Tuscany format, using 
the # separator.

Now, the Tuscany format is as defined for an "SDO URI" in the SDO Java 
spec. Whether this format has any wider usage outside SDO, I'm not sure. 
It's clear that XML defines no standard for this, but there is a popular 
convention, attributed to James Clark, which is:


See for example, the docs for javax.xml.namespace.QName::toString(), 
which sternly states "An appropriate use of this method is for debugging 
or logging for human consumption", because you cannot depend on the 
format being interoperable.

I think this is better than the SDO URI convention, in the sense that # 
is valid in a URI as introducing a fragment ID (though it would be 
pretty weird to use such as URI as a namespace), so introduces parsing 
problems when used as a URI separator. But I don't know why the SDO spec 
  writers didn't go that way.

You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to