On Wed, May 02, 2007 at 12:09:22PM +1200, Mark Robinson wrote:
> > # aptitude -vV dist-upgrade
> > Reading package lists... Done
> > Building dependency tree... Done
> > Reading extended state information
> > Initializing package states... Done
> > Building tag database... Done
> > The following packages are BROKEN:
> >   libgdal1-1.4.0 [1.4.1-4] php4 [6:4.4.4-9 -> 6:4.4.6-2]
> > The following packages are unused and will be REMOVED:
> >   libqgis0 [0.7.9+svn-20060901]
> > The following NEW packages will be automatically installed:
> >   libgdal1-1.4.0-grass [1.4.1-1] libhdf5-serial-1.6.5-0 [1.6.5-3] libqgis1 
> > [0.8.0-2]
> > The following NEW packages will be installed:
> >   libgdal1-1.4.0-grass [1.4.1-1] libhdf5-serial-1.6.5-0 [1.6.5-3] libqgis1 
> > [0.8.0-2]
> > The following packages will be upgraded:
> >   gdal-bin [1.3.2-4 -> 1.4.1-4] grass [6.2~beta1-1 -> 6.2.1-3] qgis 
> > [0.7.9+svn-20060901 -> 0.8.0-2] qgis-plugin-grass [0.7.9+svn-20060901 -> 
> > 0.8.0-2]
> >   skencil [0.6.17-7 -> 0.6.17-8]
> > 6 packages upgraded, 4 newly installed, 1 to remove and 0 not upgraded.
> > Need to get 18.5MB/20.1MB of archives. After unpacking 13.5MB will be used.
> > The following packages have unmet dependencies:
> >   php4: Depends: libapache2-mod-php4 (>= 6:4.4.6-2) but 6:4.4.4-9 is 
> > installed. or
> >                  libapache-mod-php4 (>= 6:4.4.6-2) but it is not 
> > installable or
> >                  php4-cgi (>= 6:4.4.6-2) but 6:4.4.4-9 is installed.
> >         Depends: php4-common (>= 6:4.4.6-2) but 6:4.4.4-9 is installed.
> >   libgdal1-1.4.0: Conflicts: libgdal1-1.3.2 but 1.3.2-4 is installed.
> > Resolving dependencies...
> > The following actions will resolve these dependencies:
> > 
> > Keep the following packages at their current version:
> > gdal-bin [1.3.2-4 (now)]
> > grass [6.2~beta1-1 (now)]
> > libgdal1-1.4.0 [Not Installed]
> > libgdal1-1.4.0-grass [Not Installed]
> > libqgis0 [0.7.9+svn-20060901 (now)]
> > libqgis1 [Not Installed]
> > php4 [6:4.4.4-9 (now)]
> > qgis [0.7.9+svn-20060901 (now)]
> > qgis-plugin-grass [0.7.9+svn-20060901 (now)]
> > 
> > Score is -156
> > 
> > Accept this solution? [Y/n/q/?] q
> > Abandoning all efforts to resolve these dependencies.
> > Abort.

You have programs that still strictly depends on 1.3.2, try what by explicitly 
installing libgdal1-1.4.0.

-- 
Francesco P. Lovergine


_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to