[Giovanni Mascellani]
> Well, my experience is a bit odd: first of all, I see many
> differences if I work in my main sid or in a little chroot, sid too
> (they both up-to-date).

I've only tested using a sid chroot.

> With jamvm (command: JAVACMD=jamvm josm):
>  - Inside the chroot things are going quite well, but:
>    * File type selection combo in Open file dialog is broken, and
>      doesn't influence the file view above. Anyway, I could open a .gpx
>      file, but when I tried with a .gpx.gz at first it just started to
>      eat all the CPU time it could, and after a few minutes it started
>      allocating memory on memory, and I had to kill it.
>    * Uploding changes result in a "Error while parsing: An error
>      occurred: Already connected java.net.ProtocolException" error
>      dialog.
>    * Downloading works.
>  - In my main system things are much simpler: the main window gets
>    opened, but it is empty. After a few seconds jamvm happily crashes.

I've only tested downloading so far, and as you said, it work.

> With gij-4.3 (command: JAVACMD=gij-4.3 josm):
>  - Inside the chroot the window gets opened, but it's empty. strace
>    shows that is waiting in a futex() call.
>  - Outside the chroot it happens just the same thing.

Did not test this earlier.  Tested it now, and I see the same thing.

> With gij-4.1 (command: JAVACMD=gij-4.1 josm):
>  - Inside the chroot things are similar to jamvm, but:
>     * Open file dialog is even more broken: I can't select the file I
>       want, because clicking on a file causes another file to be
>       selected and, thus, opened. Anyway, I'm able to open .gpx.gz
>       files.
>     * Downloading sometimes it ends up in unresponsive program,
>       sometimes ends up in an error dialog, sometimes works.
>     * Uploading fails as in jamvm.
>  - Outside the chroot josm crashes as with gij-4.3.

This is how I tested earlier (actually, JAVACMD=/usr/bin/gij-4.1 josm)
and download worked every time for me.

> Quite strange, isn't it? I think that, right now, josm isn't in
> shape to be released in main, and should move to contrib depending
> on Sun's JRE.

Well, I do not agree, as I believe just having downloading working
with one of the free JVMs is enough to justify its presense in main.

Besides, the SUN JRE is on its way into main, and it would be a waste
of time and effort to move josm to contrib just to move it back to
main shortly thereafter.

But we should keep it out of Lenny until we are know more about the
OSM web API stability, to avoid having to drop it from Lenny after it
become stable.

Happy hacking,
Petter Reinholdtsen

Pkg-grass-devel mailing list

Reply via email to