On Thu, 2009-06-11 at 21:22 +0200, Andreas Putzo wrote:
> On Jun 11  18:22, Adam D. Barratt wrote:
> > Andreas Putzo wrote:
> >> gpsdrive: symbol lookup error:
> >> /usr/lib/mapnik/0.5/input/postgis.input: undefined symbol:
> >> _ZN5boost5mutex7do_lockEv
> >
> > Hmmm, how did you produce that error? The version of /usr/bin/gpsdrive 
> > I've built is linked against mapnik 0.6 (that rather being the point of 
> > getting the bug fixed in the first place ;-) but it's possible something 
> > is still picking up a 0.5 dependency somewhere.
> 
> > (and thinking about it the build-dep should probably also be bumped to  
> > require libmapnik-dev >= 0.6, to ensure that it gets upgraded in chroots 
> > if already present).
> 
> I built the package with pbuilder and tried it in an up-to-date sid
> chroot. 

I meant more specifically. :-) I tried it on up-to-date sid as well, but
I obviously didn't try the right thing, as I hadn't spotted the
problem. :-/

> > What does "ldd /usr/bin/gpsdrive | egrep mapnik"  give you?
> 
> $ ldd /usr/bin/gpsdrive |grep mapnik
>     libmapnik.so.0.6 => /usr/lib/libmapnik.so.0.6 (0xb748b000)
> 
> I still had libmapnik0.5 installed. If i deinstall it, gpsdrive runs
> without error.
> 
> Just noticed there is /usr/lib/mapnik/0.5 hardcoded in 
> debian/patches/96-mapnik-plugins-dir.dpatch. I guess that's the problem.

Yep, sounds likely.

It sounds like you've got this under control? If so and you're likely to
upload a new version shortly then I'll ignore the NMU; a maintainer
upload is generally preferable and you should be able to test it more
usefully than I can :)

Regards,

Adam



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to