On Thu, Aug 29, 2013 at 4:14 PM, Jérémy Lal <kapo...@melix.org> wrote:
> On 29/08/2013 15:40, Mathieu Malaterre wrote:
>> Package: npm
>> Severity: normal
>>
>> I cannot seems to get npm (experimental package) to run nicely, it fails 
>> with:
>
> oh boy, just give me the command you run...
>
> anyway your bug is upstream :
> https://github.com/gruntjs/grunt/pull/886

I am not clear exactly which dep is setting 2.2.0rc (vs 2.2.0-rc), but
here it goes:

$ cat  package.json
{
  "name": "OpenSeadragon",
  "version": "0.9.130",
  "description": "Provides a smooth, zoomable user interface for
HTML/Javascript.",
  "devDependencies": {
    "grunt": "~0.4.0",
    "grunt-contrib-compress": "~0.5.0",
    "grunt-contrib-concat": "~0.1.2",
    "grunt-contrib-jshint": "~0.6.0",
    "grunt-contrib-uglify": "~0.2.2",
    "grunt-contrib-qunit": "~0.2.0",
    "grunt-contrib-connect": "~0.1.2",
    "grunt-contrib-watch": "~0.2.0",
    "grunt-contrib-clean": "~0.4.0",
    "grunt-git-describe": "~2.0.0",
    "grunt-text-replace": "~0.3.2"
  },
  "scripts": {
    "test": "grunt test"
  }
}

$ npm install
[...]
npm http 304 https://registry.npmjs.org/underscore.string
npm ERR! Error: No compatible version found: underscore.string@'~2.2.0rc'
npm ERR! Valid install targets:
npm ERR! 
["0.9.2","1.0.0","1.1.3","1.1.4","1.1.5","1.1.6","2.0.0","2.1.0","2.1.1","2.3.0","2.3.1","2.3.2","2.2.1","2.2.0-rc","2.3.3"]
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:685:10)
npm ERR!     at /usr/share/npm/lib/cache.js:607:10
npm ERR!     at saved
(/usr/share/npm/node_modules/npm-registry-client/lib/get.js:138:7)
npm ERR!     at /usr/lib/nodejs/graceful-fs/polyfills.js:133:7
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /tmp/openseadragon/npm-debug.log npm

npm ERR! System Linux 3.2.0-0.bpo.4-amd64
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! cwd /tmp/openseadragon
npm ERR! node -v v0.10.15
npm ERR! npm -v 1.2.18
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/js-yaml
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /tmp/openseadragon/npm-debug.log
npm ERR! not ok code 0


If you need the full code:

$ git clone git://github.com/openseadragon/openseadragon.git

2cts

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to