2017-09-29 19:24 GMT+02:00 Andreas Beckmann <a...@debian.org>:

> Package: node-d3-color
> Version: 1.0.3-1
> Severity: serious
> Justification: Build-Depends not satisfiable in testing
> Control: block -1 with 857986
> Control: clone -1 -2 -3 -4 -5 -6 -7 -8 -9 -10
> Control: reassign -2 node-d3-format 1.2.0-1
> Control: retitle -2 node-d3-format: B-D npm not available in testing
> Control: block -2 with 857986
> Control: reassign -3 node-d3-queue 3.0.7-1
> Control: retitle -3 node-d3-queue: B-D npm not available in testing
> Control: block -3 with 857986
> Control: reassign -4 node-d3-selection 1.1.0-1
> Control: retitle -4 node-d3-selection: B-D npm not available in testing
> Control: block -4 with 857986
> Control: reassign -5 d3-timer 1.0.7-1
> Control: retitle -5 d3-timer: B-D npm not available in testing
> Control: block -5 with 857986
> Control: reassign -6  node-filesize 3.5.10+dfsg-1
> Control: retitle -6 node-filesize: B-D npm not available in testing
> Control: block -6 with 857986
> Control: reassign -7 node-gulp-babel 7.0.0-1
> Control: retitle -7 node-gulp-babel: B-D npm not available in testing
> Control: block -7 with 857986
> Control: reassign -8 node-babel-plugin-transform-define 1.3.0-1
> Control: retitle -8 node-babel-plugin-transform-define: B-D npm not
> available in testing
> Control: block -8 with 857986
> Control: reassign -9 node-babel 6.25.0+dfsg-8
> Control: retitle -9 node-babel: B-D npm not available in testing
> Control: block -9 with 857986
> Control: reassign -10 node-babylon 6.18.0-1
> Control: retitle -10 node-babylon: B-D npm not available in testing
> Control: block -10 with 857986
>
>
> Hi,
>
> with npm not available in testing (and according to #857986 this will
> not change in the near future), these node-* packages must be kept
> out of testing, since they cannot be rebuilt in testing (regardless of
> any external resources they might need additionally).
>

Build-Depending on npm is a sign something very wrong, policy-breaking,
is happening, like downloading a npm module during build.

An example of how wrong the problem is:
```
override_dh_auto_build:
  npm install rollup
```

ouch

I cc-ed everyone to make sure this doesn't happen again.

Jérémy
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to