Hello, On sekmadienis 28 Vasaris 2010 13:46:53 George Kiagiadakis wrote: > <[email protected]> wrote: > > On Jueves 25 Febrero 2010 16:42:20 Modestas Vainius escribió: > >> Hello, > >> > >> since there is no Debian stable with KDE 4 yet and having in mind the > >> recent KDE rebranding [1], I think there will never be a better time to > >> change names of the meta-kde metapackages to match the new branding and > >> give our metapackages somewhat official names for the first time in the > >> KDE history. > >> > >> My proposal: > >> > >> kde-minimal becomes: > >> -------------------- > >> > >> Package: kde-plasma-desktop > >> Provides: kde-minimal > >> > >> Package: kde-plasma-netbook > >> Provides: kde-minimal > >> > >> kde-standard mostly remains as it is except: > >> ------------------------------------- > >> > >> Package: kde-standard > >> Depends: kde-plasma-desktop | kde-plasma-netbook, $standard_apps > > > > +=1 > > I think that's a good idea. > > >> kde-full becomes (already done in svn): > >> --------------------------------------- > >> > >> Package: kde-sc > >> Provides: kde-full > > > > "sc" alone means nothing. It should be "kde-software-compilation". But as > > Debian already implies software, it could be shortened to > > "kde-compilation". > > I also don't like "kde-sc" much. I don't think we should drop "full", > otherwise we will get the same effect that the "kde" metapackage had.
That's a valid point. So lets keep both kde-full and kde-standard (so neither will look odd) and simply make kde-full provide kde-software-compilation (hence the latter name will be more hidden). So final proposal: ------------------ Package: kde-plasma-desktop Provides: kde-minimal Depends: kdebase-runtime, plasma-desktop, kdebase-workspace, kdebase-apps Package: kde-plasma-netbook Provides: kde-minimal Depends: kdebase-runtime, plasma-netbook, kdebase-workspace, kdebase-apps Package: kde-standard Depends: kde-plasma-desktop | kde-minimal, $standard_apps Suggests: kde-plasma-desktop, kde-plasma-netbook Package: kde-full Provides: kde-software-compilation Depends: kde-plasma-desktop, kde-plasma-netbook, $the_rest_of_kdesc NOTE: for this to work, kdebase-workspace metapackage should have plasma- desktop | plasma-netbook in Depends. ----------------- I have also introduced kde-sc-dev-latest (odd name, open for suggestions) which is about keeping KDE Development platform build depends up-to-date (via breaks) without bumping various build depends for each individual KDE SC package every point release. Build depends bumping is wrong for two reasons: 1) e.g. kdenetwork 4.4.5 will probably build fine against kdelibs 4.4.[01234] just fine. 2) build depends bump would unnecessarily tighten Depends and complicate KDE migration to testing which symbol files were supposed to ease. kde-sc-dev-latest does have one side effect though as it might complicate KDE building outside chroot (e.g. it will prevent building of kdepimlibs 4.4.2 while kdebase-workspace-dev 4.4.1 is installed even if kdepimlibs does not really need anything from workspace). In order to solve this, I will probably add a custom command to pkg-kde-tools which would override distro kde-sc-dev- latest with the version without Breaks and install it on the user system. -- Modestas Vainius <[email protected]>
signature.asc
Description: This is a digitally signed message part.
-- http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk
