On Mon, Jun 13, 2011 at 15:06, Hans-Christoph Steiner <h...@at.or.at> wrote:
>
> On Jun 12, 2011, at 10:40 PM, Felipe Sateler wrote:
>
>> On Sat, Jun 11, 2011 at 22:05, Hans-Christoph Steiner <h...@at.or.at>
>> wrote:
>>>
>>> On Sat, 2011-06-11 at 19:18 +0000, Felipe Sateler wrote:
>>>>
>>>> I'm confused. You make a change for puredata >= 0.43. Does this break
>>>> puredata <0.43? The Depends field suggests that (puredata-core is non
>>>> existent until 0.43). If so, the build-depends on puredata << 0.43 is
>>>> wrong.
>>>
>>> puredata << 0.43 provides everything, headers, app, gui, doc, etc.  With
>>> 0.43, the headers are in puredata-dev and puredata is a meta package
>>> that installs everything.  I wanted to avoid having the package
>>> Build-Depend on the whole suite of packages, that's why I added the
>>> 0.43.  Plus in the future, puredata might no longer also install
>>> puredata-dev.
>>>
>>>> Also, doesn't 0.43 bring in the required headers? I think the
>>>> add_required_headers patch can be removed.
>>>
>>> Yes, the puredata-dev 0.43 package does provide those headers, but I
>>> wanted to leave in the patch for now to aid backporting and let the dust
>>> settle on the big changes that happened with the puredata package being
>>> split into puredata-gui, puredata-dev, puredata-core, etc.
>>
>> The package won't work unmodified anyways, since it Depends on
>> puredata-core, which doesn't exist until 0.43. So strictly speaking
>> the aid for backporting is incomplete (also, it installs into a
>> different dir, so that would need to be changed too).
>>
>> I suggest just dropping the << 0.43 option, since it misleads into
>> thinking it could actually work unchanged with 0.42.
>>
>>
>> Please update the changelog. I have reviewed this and will upload
>> tomorrow afternoon (GMT-4, so probably past midnight in europe).
>
>
> Ok, makes sense, I removed the << 0.43 and pushed.

Offering puredata as an option is wrong too (it still allows 0.42)

-- 

Saludos,
Felipe Sateler

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to