Am 2018-03-02 18:43, schrieb Heather Ellsworth:
Forwarding these questions to the KWin and plasma-devel mailing lists.

-------- Forwarded Message --------
Subject: Re: kwin display issue on librem5
Date: Wed, 28 Feb 2018 12:59:39 -0700
From: Heather Ellsworth <>
CC:, Guido Günther <>, Nicole
Faerber <>

On 02/28/2018 11:53 AM, Heather Ellsworth wrote:
Hi Roman,

I've been working with Bhushan to get plasma mobile up and running on
our prototype board and we're having an issue displaying the content.
Attached is a photo (display_issue.jpg) showing the issue.

We can force the software framebuffer (export KWIN_COMPOSE=Q) to get
proper rendering (good_display_forced_framebuffer.jpg) but we don't want
to force this.

Guido pointed me to a helpful article:

I tried the various tests suggested in that article and the nested setup works fine, there are no fatal errors, and trying on the tty worked ok.
I should mention that in both the nested setup and trying on the tty,
the mouse is not visible but is active because i can click the drop down
menus and whatnot, I just can't see where the cursor is.

It is also worth mentioning that I also tried the following
troubleshooting steps:

1. No kwin_wayland session running

2. Get the dbus environment:
$ env | grep DBUS > /tmp/env
$ cat /tmp/env

3. In an ssh session to the board, export the vars:
$ export
$ export DBUS_SESSION_BUS_PID=1268

4. In a tty on the board, launch kwin_wayland:
$ kwin_wayland --drm plasma-phone

change this to:

gdb --args kwin_wayland plasma-phone

this should give a backtrace when KWin crashes. Then we have a better idea on where it fails.

I would also suggest to add --xwayland for the beginning. It's quite likely that something in the session requires it and thus creates issues.

And you don't need the --drm. It's the default if no DISPLAY or WAYLAND_DISPLAY is set.


Reply via email to