Am Sat, 10 Mar 2018 11:17:36 +0100
Michal Babej <franz.netyka...@runbox.com> schrieb:

> Hi,
> 
> > Trying to prepare an adaption of POCL 1.1 to FreeBSD (CURRENT at the
> > moment), using LLVM/CLANG 5, compilation runs well, but the final
> > tests fail due to the initial error in pocl_version_check, like
> > 
> > pocl_version_check 
> > ..................................................................***Failed 
> >  
> 
> > Does anybody else face this error?
> >   
> 
> That test does one thing: it loads OpenCL and checks that the platform
> version matches "OpenCL 1.2 pocl X.Y". Two common ways this could fail
> are 1) you have another OpenCL platform installed, or 2) loading
> libpocl.so fails (usually due to linking problems).
> 
> If you have ocl-icd installed as ICD loader, then an easy check is:
> 
> source <path-to-pocl-source-dir>/tools/scripts/devel-envs.sh
> clinfo

The script devel-envs.sh is a Bourne shell script, so I guess "sourcing" it 
like c shell
scripts isn't appropriate here, it fails, executed from POCL's BUILD directory:

source ./tools/scripts/devel-envs.sh
libs_subdir=.: Command not found.
export: Command not found.
export: Command not found.
export: Command not found.
export: Command not found.

[...]

Executing

# (sh ./tools/scripts/devel-envs.sh && clinfo)

gives me 

Unable to find symbol pthread_mutexattr_setkind_np version (null). Aborting.
Abort

This is something I see lately very often due to some weirdness in registering 
ICDs. This
is with compiling pocl with LLVM 6. 

> 
> from pocl's BUILD directory. If it prints 0 platforms then likely you
> have linking issues. Or you could build pocl with -DENABLE_ICD=0 and
> it'll fail linking the tests, if there are any problems.

Installed (on my test box) is ocl-icd 2.2.12, on another box there is the 
regular ocl-icd
package/port devel/ocl-icd in the FreeBSD ports tree, which is version 2.2.11. 
this just
for the record if it matters.

> 
> Cheers,
> -- mb
> 
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> pocl-devel mailing list
> pocl-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/pocl-devel



-- 
O. Hartmann

Ich widerspreche der Nutzung oder Übermittlung meiner Daten für
Werbezwecke oder für die Markt- oder Meinungsforschung (§ 28 Abs. 4 BDSG).

Attachment: pgpwygYf8oEyB.pgp
Description: OpenPGP digital signature

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
pocl-devel mailing list
pocl-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/pocl-devel

Reply via email to