On 15/01/13 21:39, Roger Bishop Jones wrote:
On Tuesday 15 Jan 2013 09:27:06 Roger Bishop Jones wrote:
On Tuesday 15 Jan 2013 07:43:30 Phil Clayton wrote:
When you select Tools->Templates, do you see the templates dialog box
(with very small buttons) or does nothing happen?  (The first is a known
issue that is easily worked around.)


I havn't used the templates for a long time, but I see now that I don't have
them either (in 2.9.1w5).
I have unhashed the template include line in Xpp but the Tools menu in Xpp
still has Templates greyed out.

On further investigation I do get the templates if I use an Xpp file in which
the include for the templates is omitted (hashed), but if I use an include
even with a full pathname it doesn't seem to pick up the template file.
This applies also to the XppKeyboard file as well, I can't get the include to
work, but if the include is omitted the behaviour corresponds to the issued
XppKeyboard file (so far as I can see).

In an X/Motif resource file, I believe '!' starts a comment and include is a macro so must have a '#' before it, as in the Xpp file distributed with ProofPower. Roger - do you still get the issue with #include ?

To find out what is disabling the Templates menu item, it is worth trying

  PPENVDEBUG=1 xpp

and checking that the paths reported in the terminal look sensible. In particular, what is given for XUSERFILESEARCHPATH ? Also, if %N is replaced by XppTemplates does any element of the path refer to a file on the file system?

Phil


_______________________________________________
Proofpower mailing list
Proofpower@lemma-one.com
http://lemma-one.com/mailman/listinfo/proofpower_lemma-one.com

Reply via email to