On 15 Jan 2013, at 22:12, Phil Clayton wrote:
> In an X/Motif resource file, I believe '!' starts a comment and include is a 
> macro so must have a '#' before it, as in the Xpp file distributed with 
> ProofPower.

That is correct. It may also be worth knowing that the file name in a #include 
directive in a resource file is interpreted relative to the directory in which 
the resource file was found.

>  Roger - do you still get the issue with #include ?
> To find out what is disabling the Templates menu item, it is worth trying

N.b., the output from this does not appear on the xpp GUI, but on standard 
error, i.e., in the Terminal window where you ran the command.

> and checking that the paths reported in the terminal look sensible.  In 
> particular, what is given for XUSERFILESEARCHPATH ?  Also, if %N is replaced 
> by XppTemplates does any element of the path refer to a file on the file 
> system?

I am hoping that Sarah who asked the original question that prompted this 
thread has solved her problem. In case not, here is a bit more information. 
Sarah wrote:

>> i have a problem in activating templates in the tools menu PPXpp-2.9.1w2 
>> that i have installed it...the templates in the tools menu is not 
>> active...could you please tell me that how to activate it...how to customize 
>> xpp resource file (application defaults file) ??? 
>> The example resource file uses #include directives to include two
>> files XppKeyboard and XppTemplates in my case it is XppZTemplates which 
>> define the keyboard layoiut and the behaviour of the Templates Tool. 
>> XppKeyboard and XppTemplates are set up as symbolic links to other resource 
>> files in the same directory.
>> now the problem is that i do not understand that how to include XppKeyboard 
>> and XppZTemplates in the resource file for xpp so that the templates get 
>> activated???

Apologies for any confusion about the XppKeyboard file. Only one of these is 
now supplied, so it is supplied as an actual file not a link (so the 
documentation quoted above is a little out of date). In the supplied example 
app-defaults directory, the Xpp file includes the line:
#include "XppTemplates"

and XppTemplates is a symbolic link to XppZTemplates. If the Xpp.templates 
resource that is specified in XppZTemplates is not being picked up, then this 
will result in the Templates Menu item being inactive. However, you should not 
need to change the supplied files to pick up the settings from XppZTemplates.

Most users don't need to do anything to pick up the example resource files 
supplied in the app-defaults directory in the ProofPower installation 
directory. xpp will arrange to find them there unless you have defined the 
XUSERFILESEARCHPATH (or XAPPLRESDIR) environment variables (presumably to 
specify custom resource files for other X Windows applications). As Phil says, 
running xpp with the PPENVDEBUG environment variable set as above will tell you 
whether it is using its own value for XUSERFILESEARCHPATH or yours. You may 
find that the set up for some other application has caused XUSERFILESEARCHPATH 
or XAPPLRESDIR to be defined in your shell start up files without you knowing 
about it. In any case, if xpp is using your setting, then, the simplest thing 
to do is to copy the Xpp resource files into a directory on your 

Finally, if you need to do lower level debugging of resource settings in xpp, 
then the command

        xpp -c appres Xpp

will give you copious information (in the xpp journal window) about the 
resource settings that xpp is actually seeing.



Proofpower mailing list

Reply via email to