Tony is right I think.   Your file associations were hosed.

Too bad too.   I think that "demo" software should not mess with such
things unless approved by the user.   Furthermore, they should certainly be
restored with an un-install out of sheer politeness.

I have this problem with almost every thing I install.   I combat this
syndrom with a pair of batch files that will easily straighten out the
mess.   I have found that doing it in explorer is limiting and prone to
flaky behavior.   The batch files I use are easier, quicker, and best of
all... portable.

Note my OS is NT so you may have to do it different with W2000, XP, or
whatever.    Also note that I am a diehard protel 98 user (ive got 99se but
dont use it) which is relected in the examples below.

Here are my actual batch files I use:


DumpFileAssociationsToTextFiles.bat
--------------------------------------------------------------
assoc > assoc.txt
ftype > ftype.txt
notepad assoc.txt
notepad ftype.txt

*** This dumps the current file association data to a pair of text files
that are then opened in notepad for viewing.



SetFileAssociations.bat
------------------------------------------
rem
rem ********** SET JPG FILES TO OPEN WITH MS PHOTOEDITOR ************************
rem ftype jpegfile=
rem ftype jpegfile="c:\program files\common files\microsoft 
shared\photoed\photoed.exe" %1
rem
rem ********** REMOVE ASSOCIATIONS FOR PROTEL FILES *****************************
rem assoc .lib=
rem assoc .sch=
rem assoc .prj=
rem assoc .net=
rem assoc .pcb=
rem assoc .pld=
rem assoc .rcs=txtfile
rem assoc .sdf=
rem
rem
rem ********* REASSIGN FILE TYPES BACK TO PROTEL 98 *****************************
rem ftype ProtelLibraryFile=C:\client98\client98.exe %1
rem ftype ProtelNetlistFile=C:\client98\client98.exe %1
rem ftype ProtelPCBFile=C:\client98\client98.exe %1
rem ftype ProtelProjectFile=C:\client98\client98.exe %1
rem ftype ProtelResourceFile=C:\client98\client98.exe %1
rem ftype ProtelSchematicFile=C:\client98\client98.exe %1
rem
rem
rem =========

*** This file sets the associations that I want.   I enable selected lines by removing 
the REM prior to running it.


To use these batch files, run the 1st one and look at the associations you
have currently

assoc.txt shows what program name goes with each registered file extension

.386=vxdfile
.acp=Office.ActorPreview
.act=Office.Actor
.ai=
.aif=AIFFFile
.aifc=AIFFFile
.aiff=AIFFFile
.akf=AcroExch.Key
...........................

ftype.txt shows what program gets called for each program name.

Access.Application.8=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP "%1"
Access.BlankDatabaseTemplate.8=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP 
/NEWDB "%1"
Access.DatabaseWizardTemplate.8=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP 
/DBWIZ "%1"
Access.Extension.8=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP "%1"
Access.MDEFile.8=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP "%1"
Access.ShortCut.Form.1=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP /SHELLSYSTEM 
[OpenForm "%1"]
Access.ShortCut.Macro.1=C:\hscapps\office97\Office\MSACCESS.EXE /NOSTARTUP 
/SHELLSYSTEM [ShellOpenMacro "%1"]
..................


So after I check what the associations are, I'll open the 2nd batch file
and edit existing lines or add new ones to manipulate the associations to
whatever I want.   Then I run it.

Finally I run the 1st batch file again to check if my changes came out
okay.


Hope you found this usefull
Dave Lewis








"Tony Karavidas" <[EMAIL PROTECTED]> on 09/05/2002 01:57:21 PM

Please respond to "Protel EDA Forum" <[EMAIL PROTECTED]>

To:    "'Protel EDA Forum'" <[EMAIL PROTECTED]>,
       [EMAIL PROTECTED]
cc:

Subject:  Re: [PEDA] DXP


Relax man. It's just a simple association that got linked to DXP. You
can easily link your cam files back to the external camtastic. It's not
messing with the files. When I first started to read your post, I was
thinking DXP was editing your old cam files. It's not.

It happens to be the 'latest' release of camtastic, right? It's now
buried inside of DXP. When I upgrade Photoshop 5 to Photoshop 6, I
expect Photoshop 6 to open my PSD files. It's the same thing.


> -----Original Message-----
> From: Back, Norb [mailto:[EMAIL PROTECTED]]
> Sent: Thursday, September 05, 2002 1:17 PM
> To: [EMAIL PROTECTED]
> Subject: [PEDA] DXP
>
>
> Why the #%@* is DXP messing with older cam files!
> I just made some cam files using 99SE went to
> the folder were the are stored and all the files
> have the pretty camtastic icon and no .label.
> I opened a cam folder made in 2000 same shit.
> If you click on one of the files DXP starts
> This was the last straw
> I don't need some dam program messing with my
> Gerber files or any thing else.
> We upgraded one seat just to check it out( what a joke)
> The box is under my desk and the program is removed
> from my computer
> I should return it and get my money back
>
>
> **************************************************************
> **********
> * Tracking #: FAFE766A041A164C868E8EF1BD39EF37300A7C24
> *
> **************************************************************
> **********
>
>






* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/proteledaforum@techservinc.com
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to