This has just happened to me again!!!  I took notes this time.
The exact message which appears is:

"ECO Action Failed.
 PcbName.PcbDoc|PCB|Add
 Components|Add|Designator_number|to|PcbName.PcbDoc|Designator_number
 to PCBName.PcbDoc"

In this case I:
- Worked on the Schematic for maybe 1/2 hour.
- left system idle for awhile (maybe 2 hours,  with DXP running).
- Worked on the schematic for maybe another 1/2 hour.
- compiled the Project.
- did an Update PCB.
- All appeared to go ok,  my most recent changes were added.
- I did however note that a footprint was not brought in,  this has
been this way for a few days now,  and was not related to the changes I
made tonight..
- I investigated the missing footprint.  I found the footprint existed
in a library which was not in the list of available PCB libraries.
(this footprint *was* previewable within the Schematic library preview
panel however.)
- I loaded the library the footprint was available in. (source)
- I loaded my user library. (destination)
- I copied the component from one library into the other (visible)
library.
- I centered the new component in destination (user) library.
- I renamed the footprint to the footprint name it was unable to find.
- there was a strange "designator" string in the destination library.
This did not appear to be in the source library.  When I tried to go to the
top overlay and delete it,  nothing seemed to happen.  I checked on
other layers,  and then looked back on the top overlay,  and it was gone.  hmmm.
- I then ran Update PCB again.
- The error message occurred after pressing the "Execute Changes" push button
in the "Engineering Change Order" Dialog.
- Validate changes creates a green status check for "Add components",
 even when the error is occurring.
- Repeated attempts to rerun "Update PCB" and "Execute Changes" continue to fail.

 I closed DXP,  restarted DXP,  compiled the Project,  did an
 "Update PCB".  It all now works.  The missing footprint is brought in,
 and there are no ECO action failed messages.

 I'm not sure what,  if any,  of the above are significant steps to
 reproduce the problem.  But this is the approximate sequence that
 led to the problem,  at least in this case.  I have not tried to see
 if it is repeatable.

---Phil


PS> Mike,

PS> I have seen DXP (SP2 W2k SP4) do something very similar to this.  In fact it just
PS> happened to me (again) not 5 mins ago.  Add a few parts to the schematic,
PS> work awhile,  make some changes,  do an update PCB,  and the new added parts are 
not
PS> brought in.  I believe I also got a dialog message,  something or other
PS> about being "unable to execute ECO?..." The message once it starts
PS> happening is very repeatable.  Close everything down,  restart DXP,  then
PS> it works just fine,  no more message,  no more problems.

PS> Sounds like a similar problem,  so my guess is it is not you.

PS> It will be unfortunate if this problem has persisted since SP2,
PS> Through the SP3 PR,  and on into P2004.  It seems to happen frequently
PS> enough that it should have been found and fixed by now.  Like I say I've
PS> seen it happen at least twice now,  just in the last week.

PS> ---Phil


e>> It is now afternoon, the netlist I received this morning is
e>> obsolete.  No problem.  There are only changes are 4 footprints,
e>> SO8 TO SO14.  I can handle that I boast to the customer.  I modify
e>> his netlist accordingly. Cough Cough Choke, 2004 will not update
e>> the parts no matter what I do.   I shut everything down, bring it
e>> back up and one part is updated to S014.  This can not be me.  

e>> Is there anyone out there that has actally done this proceedure
e>> 100 times and not just read about it?  It has to be buggy if only
e>> one part changed.  ARGHH


e>> Mike Reagan







* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/[EMAIL PROTECTED]
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to