----- Original Message -----
> From: "TheLoneStranger" <mark.she...@edftrading.com>
> To: proton@qpid.apache.org
> Sent: Tuesday, May 27, 2014 11:41:10 AM
> Subject: Re: Help connecting with SSL
> Hi Ken,
> Thanks for the help so far.
> I have tried the msgr-send.c in the excample directory, and it gives the
> same error as before..
> "CONNECTION ERROR invalid credentials"
> The underlying cause of this is a call to pn_ssl_domain_set_credentials
> which calls the pn_ssl_domain_set_credentials in the ssl_stub.c file.
> So, I suppose my next question is how do I switch to use the proper
> pn_ssl_domain_set_credentials, i.e. the one from the ssl/openssl.c file.

Aha!  Yes, I see the problem now - if you are calling ssl_stub.c, that means 
you haven't built against the OpenSSL library.   Proton uses OpenSSL for its 
SSL implementation.  When you configure your Proton build, it looks for the 
presence of the OpenSSL libraries on your system.  If they are not present, it 
uses ssl_stub.c instead, which will not allow you to try to set up SSL 
connections (since the OpenSSL libraries are not present).

What system are you trying to build your clients on?  OpenSSL is not supported 
on Windows, btw, and Proton does not yet have support for SSL on windows - see 
Cliff's previous email on this topic:


> Regards,
> --
> View this message in context:
> http://qpid.2158936.n2.nabble.com/Help-connecting-with-SSL-tp7608636p7608666.html
> Sent from the Apache Qpid Proton mailing list archive at Nabble.com.


Reply via email to