2009/7/20 Mona Remlawi <mona.reml...@gmail.com>:
>
> Hello prototypers,
>
> I'm getting a basic error (in selectors) in *IE8/FF3* and don't think
> anyone has reported it yet -- or maybe did, i searched but not
> extensively.
> The problem is that the Element#selector fails when invoked on an
> Element that has a '.' in its id.
> I've put a small unit test on pastie, you just need to get a copy of
> unittest.js from scriptaculous (and test.css if you like colors :) )
> http://pastie.org/552134
>
> Tested with both version#1.6.0.3 and version#1.6.1RC#3 with the same results.
>
> Any help is greatly appreciated, I'm trying to debug on my own but
> doubt i'll reach somewhere.
>
> cheers
>
> --
> mona
>
> >
>

I don't know how feasible it it, but maybe globally changing your IDs
to use "_" rather than "." would be a quick and easy fix.



-- 
-----
Richard Quadling
Zend Certified Engineer : http://zend.com/zce.php?c=ZEND002498&r=213474731
"Standing on the shoulders of some very clever giants!"
ZOPA : http://uk.zopa.com/member/RQuadling

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to