On Mon, Apr 27, 2015 at 3:41 PM, Matthew Robb <matthewwr...@gmail.com> wrote:
> I know this isn't the biggest deal but I think naming the function
> distribute is highly suggestive, why not just expose this as
> `childListChangedCallback` ?

Because that doesn't match the actual semantics. The callback is
invoked once distribute() is invoked by the web developer or
distribute() has been invoked on a composed ancestor ShadowRoot and
all composed ancestor ShadowRoot's have already had their callback
run. (Note that the distribute callback and the distribute method are
different things.)

Since the distribute callback is in charge of distribution it does in
fact make sense to call it such I think.


Reply via email to