Hi everyone, 
in the last days, I have finally finished my project and I started using 
PyInstaller, actually a great and easy tool for compiling python!

My project, that uses a Raspberry Pi 2 and Jessie OS, is composed of files 
for Python2.7 and files for Python3 and here is the problem:

First, I have successfully installed PyInstaller on my Raspberry using pip 
-> "sudo pip install pyinstaller", and after I compiled one of my files 
that uses Python2.7 using "sudo pyinstaller --onefile my_file.py". The 
result is great and everything worked.

Afterward, I have installer PyInstaller per Python3 using "sudo pip3 
install pyinstaller", and I have compiled another file that uses Python3 
using  "sudo pyinstaller --onefile my_file_for_python3.py". The result is 
great and everything worked.

HERE is the problem: if now I want to compile the first file that uses 
Python2.7, PyInstaller is not able to prperly do it because it will use 
always the Python3 compiler (I can see in the log).....it seems once you 
upgrade to the version of PyInstaller for python3, every file will be 
compiled using Python3 compiler without choice.

Is anyone able to guide me how to fix this problem? I searched in the 
PyInstaller manual but I was not able to find any option to specify the 
compiler on the command line

Thanks in advance

You received this message because you are subscribed to the Google Groups 
"PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to pyinstaller+unsubscr...@googlegroups.com.
To post to this group, send email to pyinstaller@googlegroups.com.
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.

Reply via email to