Benjamin Peterson wrote:
On Wed, Jun 11, 2008 at 1:03 PM, Raymond Hettinger <[EMAIL PROTECTED]> wrote:
"Function names should be lowercase, with words separated by underscores as
necessary to improve readability." -- PEP 8
If I'm reading this correctly, then underscores are not required
everywhere. Can some of these be shortened?
function:: active_count()
method:: Thread.get_name()
method:: Thread.is_alive()
method:: Thread.is_daemon()
method:: Thread.set_daemon(daemonic)
In some cases, the mental pronounciation changes and affects my perception
of meaning. For example, Thread.setName or Thread.setname both feel like a
setter to me, but Thread.set_name causes a mental pause and a momentary
double-take (is it the name of a set?).
Actually, in this case, I think the Pythonic thing to do would be to
use properties.
Thus exposing those details as thread.name, thread.alive,
thread.daemonic (with the first two being read-only and the last
read/write)?
+1 for that approach on the threading.Thread and multiprocessing.Process
classes.
Not sure what to do about the active thread count function - shortening
it as Raymond suggests would probably be fine.
Cheers,
Nick.
--
Nick Coghlan | [EMAIL PROTECTED] | Brisbane, Australia
---------------------------------------------------------------
http://www.boredomandlaziness.org
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe:
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com