>> Should it be...
>>
>> 2.n : .is_alive()
>> 2.n+1 : .is_alive() (deprecated), .alive (recommended)
>> 2.n+2 : .alive
Barry> Personally, I'd go with a property .is_alive
I'm not fond of using a property for this since it can lull you into the
false belief that what you are doing is less expensive than it really is
(attribute access vs method call). I think this is a case where explicit is
better than implicit.
Skip
_______________________________________________
Python-Dev mailing list
[email protected]
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe:
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com