On Sat, May 22, 2010 at 4:12 PM, Brian Quinlan <br...@sweetapp.com> wrote: > Rename "executor" => "executer"
-1 for consistency with Java. > Rename "submit" to "apply" "apply" focuses attention on the function object, while "submit" focuses attention, properly I think, on the fact that you're handing something to the executor to run. So -1. > Rename "done" to "finished" "done" is nice and short, and I don't think "finished" or "completed" will be any less prone to people thinking the task actually ran. So -1. > Rename "not_finished" to "pending" +0.5. Doesn't matter that much, but pending is used elsewhere in the proposal for this concept. On the other hand, "pending" could be thought to refer to the state before "running". Possibly "finished" should be renamed to "done" here, since it's described as '"finished", contains the futures that completed (finished or were cancelled)', which uses "finished" for two different concepts. > Rename "FIRST_COMPLETED" to "ONE_COMPLETED" "ONE_COMPLETED" could imply that the first result set must contain exactly one element, but in fact, if multiple tasks finish before the waiting thread has a chance to wake up, multiple futures could be returned as done. So -1. And like my other post, I won't argue about these, leaving the actual decision up to Brian and Jesse. _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com