On Thu, 13 Oct 2016 18:24:43 +0200
Laurent Vivier <lviv...@redhat.com> wrote:
> Rename cpu_exec_exit() with cpu_exec_unrealize():
> cpu_exec_exit() is undoing what it has been done by cpu_exec_realize(), so
> call it cpu_exec_unrealize().
a separate patch???
> diff --git a/exec.c b/exec.c
> index 374c364..885dc79 100644
> --- a/exec.c
> +++ b/exec.c
> @@ -596,7 +596,7 @@ AddressSpace *cpu_get_address_space(CPUState *cpu, int
> -void cpu_exec_exit(CPUState *cpu)
> +void cpu_exec_unrealize(CPUState *cpu)
> static void cpu_common_finalize(Object *obj)
> CPUState *cpu = CPU(obj);
> - cpu_exec_exit(cpu);
> + cpu_exec_unrealize(CPU(obj));
if it's unrealize then it should be called at cpu_unrealize() time
and not at _finalize().
We've skipped this change during previous release merge window
because it was too late and would touch all targets and make already
huge hotplug series even bigger.
Now since you are doing all targets sweep/cleanup anyway,
it's good time to move it to unrealize() time.