On 01/03/2018 11:33, Liu, Yi L wrote:
> From: Peter Xu <pet...@redhat.com>
> IOMMU notifiers before are mostly used for [dev-]IOTLB stuffs. It is not
> suitable for other kind of notifiers (one example would be the future
> virt-svm support). Considering that current notifiers are targeted for
> per memory region, renaming the iommu notifier definitions.
> This patch has following changes:
> * all the notifier types from IOMMU_NOTIFIER_* prefix into IOMMU_MR_EVENT_*
> to better show its usage (for memory regions).
> * rename IOMMUNotifier to IOMMUMRNotifier
> * rename iommu_notifier to iommu_mr_notifier
Do you need this? Could the IOMMUSVANotifier simply be renamed to
> Signed-off-by: Peter Xu <pet...@redhat.com>
> Signed-off-by: Liu, Yi L <yi.l....@linux.intel.com>