On 06/03/2018 12:03, Liu, Yi L wrote:
> On Tue, Mar 06, 2018 at 11:18:43AM +0100, Paolo Bonzini wrote:
>> On 05/03/2018 09:42, Liu, Yi L wrote:
>>>> In general I think it's better to change your names from "assigned_dev"
>>>> to "sva_dev", because the point of the list is to only iterate over
>>>> devices that might be interested in using SVA.
>>> For "assigned_dev", my purpose is to distinguish "assigned devices" from
>>> emulated devices. Only the SVA usage on "assigned devices" is cared here.
>>> But it is true only SVA capable device is interested. So I may need to
>>> rename it as "assigned_sva_dev". How about your opinion?
>> What you care about is not whether the device assigned, but rather
>> whether it called or not pci_setup_sva_ops.  Currently only VFIO does
>> this, but that's not a requirement.  Hence my suggestion of calling it
>> sva_dev.
> Yes, only VFIO calls pci_setup_sva_ops so far, but it should not limited to.
> I'll apply in next version.

For what it's worth, I agree with David's suggestion for naming (so
pci_setup_pasid_ops, pasid_dev, etc.)


Reply via email to